Mazda-speed.com
July 04, 2020, 06:13:40 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Mazda-speed.com is no longer open and is now a read-only site. For Mazdaspeed Miata discussions, please visit the Mazdaspeed section on Miata.net.
 
   Home   Help Login Register  
Pages: 1 [2]   Go Down
  Print  
Author Topic: My Fab9Tuning experience (and product reviews)  (Read 11267 times)
0 Members and 1 Guest are viewing this topic.
04TitaniumGrayPhilly
Forceful Driver
Fifth Gear
*****
Posts: 2933


Soviet Stig


WWW
« Reply #15 on: September 24, 2014, 06:53:45 PM »

I can see why things like this can happen and it sucks for everyone. As I understand Fab9 is still a fairly small operation (or was when these kits first hit market) so they probably didn't have every aftermarket ECU available to them for testing. Even with my MS2X by Reverant, I had to go through 3 modules to finally get it correct. The first one fried due to my dwell settings, the second one broke up in boost, but as my tuner tells me now, the 3rd module works perfectly.

The difference is I've had the kit almost a year and anytime I have a problem I get a good resolution, even this far down the road.
Logged

2004 Mazdaspeed Miata #2373 - 328whp and 308wtq/ 2500lbs
ARTech, EFR6258, XIDA, Maxxis RC-1, 3.63 R&P
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!

Copyright 2007-2016, Eunos Communications LLC